salt.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648
  1. %if ! (0%{?rhel} >= 6 || 0%{?fedora} > 12)
  2. %global with_python26 1
  3. %define pybasever 2.6
  4. %define __python_ver 26
  5. %define __python %{_bindir}/python%{?pybasever}
  6. %endif
  7. %global include_tests 1
  8. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  9. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
  10. %{!?pythonpath: %global pythonpath %(%{__python} -c "import os, sys; print(os.pathsep.join(x for x in sys.path if x))")}
  11. %define _salttesting SaltTesting
  12. %define _salttesting_ver 2015.2.16
  13. Name: salt
  14. Version: 2014.7.2
  15. Release: 2%{?dist}
  16. Summary: A parallel remote execution system
  17. Group: System Environment/Daemons
  18. License: ASL 2.0
  19. URL: http://saltstack.org/
  20. Source0: http://pypi.python.org/packages/source/s/%{name}/%{name}-%{version}.tar.gz
  21. Source1: https://pypi.python.org/packages/source/S/%{_salttesting}/%{_salttesting}-%{_salttesting_ver}.tar.gz
  22. Source2: %{name}-master
  23. Source3: %{name}-syndic
  24. Source4: %{name}-minion
  25. Source5: %{name}-api
  26. Source6: %{name}-master.service
  27. Source7: %{name}-syndic.service
  28. Source8: %{name}-minion.service
  29. Source9: %{name}-api.service
  30. Source10: README.fedora
  31. Source11: logrotate.salt
  32. Patch0: skip_tests_%{version}.patch
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  34. BuildArch: noarch
  35. %ifarch %{ix86} x86_64
  36. Requires: dmidecode
  37. %endif
  38. Requires: pciutils
  39. Requires: yum-utils
  40. %if 0%{?with_python26}
  41. BuildRequires: python26-devel
  42. Requires: python26-crypto
  43. Requires: python26-jinja2
  44. Requires: python26-m2crypto
  45. Requires: python26-msgpack
  46. Requires: python26-PyYAML
  47. Requires: python26-requests
  48. Requires: python26-zmq
  49. %else
  50. %if ((0%{?rhel} >= 6 || 0%{?fedora} > 12) && 0%{?include_tests})
  51. BuildRequires: m2crypto
  52. BuildRequires: python-crypto
  53. BuildRequires: python-jinja2
  54. BuildRequires: python-msgpack
  55. BuildRequires: python-pip
  56. BuildRequires: python-zmq
  57. BuildRequires: PyYAML
  58. BuildRequires: python-requests
  59. BuildRequires: python-unittest2
  60. # this BR causes windows tests to happen
  61. # clearly, that's not desired
  62. # https://github.com/saltstack/salt/issues/3749
  63. BuildRequires: python-mock
  64. BuildRequires: git
  65. BuildRequires: python-libcloud
  66. %if ((0%{?rhel} == 6) && 0%{?include_tests})
  67. # argparse now a salt-testing requirement
  68. BuildRequires: python-argparse
  69. %endif
  70. %endif
  71. BuildRequires: python-devel
  72. Requires: m2crypto
  73. Requires: python-crypto
  74. Requires: python-jinja2
  75. Requires: python-msgpack
  76. Requires: PyYAML
  77. Requires: python-requests
  78. Requires: python-zmq
  79. %endif
  80. %if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
  81. Requires(post): chkconfig
  82. Requires(preun): chkconfig
  83. Requires(preun): initscripts
  84. Requires(postun): initscripts
  85. %else
  86. %if 0%{?systemd_preun:1}
  87. Requires(post): systemd-units
  88. Requires(preun): systemd-units
  89. Requires(postun): systemd-units
  90. %endif
  91. BuildRequires: systemd-units
  92. Requires: systemd-python
  93. %endif
  94. %description
  95. Salt is a distributed remote execution system used to execute commands and
  96. query data. It was developed in order to bring the best solutions found in
  97. the world of remote execution together and make them better, faster and more
  98. malleable. Salt accomplishes this via its ability to handle larger loads of
  99. information, and not just dozens, but hundreds or even thousands of individual
  100. servers, handle them quickly and through a simple and manageable interface.
  101. %package master
  102. Summary: Management component for salt, a parallel remote execution system
  103. Group: System Environment/Daemons
  104. Requires: %{name} = %{version}-%{release}
  105. %if (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
  106. Requires: systemd-python
  107. %endif
  108. %description master
  109. The Salt master is the central server to which all minions connect.
  110. %package minion
  111. Summary: Client component for Salt, a parallel remote execution system
  112. Group: System Environment/Daemons
  113. Requires: %{name} = %{version}-%{release}
  114. %description minion
  115. The Salt minion is the agent component of Salt. It listens for instructions
  116. from the master, runs jobs, and returns results back to the master.
  117. %package syndic
  118. Summary: Master-of-master component for Salt, a parallel remote execution system
  119. Group: System Environment/Daemons
  120. Requires: %{name} = %{version}-%{release}
  121. %description syndic
  122. The Salt syndic is a master daemon which can receive instruction from a
  123. higher-level master, allowing for tiered organization of your Salt
  124. infrastructure.
  125. %package api
  126. Summary: REST API for Salt, a parallel remote execution system
  127. Group: System administration tools
  128. Requires: %{name}-master = %{version}-%{release}
  129. %description api
  130. salt-api provides a REST interface to the Salt master.
  131. %package cloud
  132. Summary: Cloud provisioner for Salt, a parallel remote execution system
  133. Group: System administration tools
  134. Requires: %{name}-master = %{version}-%{release}
  135. %description cloud
  136. The salt-cloud tool provisions new cloud VMs, installs salt-minion on them, and
  137. adds them to the master's collection of controllable minions.
  138. %package ssh
  139. Summary: Agentless SSH-based version of Salt, a parallel remote execution system
  140. Group: System administration tools
  141. Requires: %{name} = %{version}-%{release}
  142. %description ssh
  143. The salt-ssh tool can run remote execution functions and states without the use
  144. of an agent (salt-minion) service.
  145. %prep
  146. %setup -c
  147. %setup -T -D -a 1
  148. cd %{name}-%{version}
  149. %patch0 -p1
  150. %build
  151. %install
  152. rm -rf %{buildroot}
  153. cd $RPM_BUILD_DIR/%{name}-%{version}/%{name}-%{version}
  154. %{__python} setup.py install -O1 --root %{buildroot}
  155. # Add some directories
  156. install -d -m 0755 %{buildroot}%{_var}/cache/salt
  157. install -d -m 0755 %{buildroot}%{_sysconfdir}/salt
  158. install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.conf.d
  159. install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.deploy.d
  160. install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.maps.d
  161. install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.profiles.d
  162. install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.providers.d
  163. # Add the config files
  164. install -p -m 0640 conf/minion %{buildroot}%{_sysconfdir}/salt/minion
  165. install -p -m 0640 conf/master %{buildroot}%{_sysconfdir}/salt/master
  166. install -p -m 0640 conf/cloud %{buildroot}%{_sysconfdir}/salt/cloud
  167. install -p -m 0640 conf/roster %{buildroot}%{_sysconfdir}/salt/roster
  168. %if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
  169. mkdir -p %{buildroot}%{_initrddir}
  170. install -p %{SOURCE2} %{buildroot}%{_initrddir}/
  171. install -p %{SOURCE3} %{buildroot}%{_initrddir}/
  172. install -p %{SOURCE4} %{buildroot}%{_initrddir}/
  173. install -p %{SOURCE5} %{buildroot}%{_initrddir}/
  174. %else
  175. mkdir -p %{buildroot}%{_unitdir}
  176. install -p -m 0644 %{SOURCE6} %{buildroot}%{_unitdir}/
  177. install -p -m 0644 %{SOURCE7} %{buildroot}%{_unitdir}/
  178. install -p -m 0644 %{SOURCE8} %{buildroot}%{_unitdir}/
  179. install -p -m 0644 %{SOURCE9} %{buildroot}%{_unitdir}/
  180. %endif
  181. install -p %{SOURCE10} .
  182. mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d/
  183. install -p -m 0644 %{SOURCE11} %{buildroot}%{_sysconfdir}/logrotate.d/salt
  184. %if ((0%{?rhel} >= 6 || 0%{?fedora} > 12) && 0%{?include_tests})
  185. %check
  186. cd $RPM_BUILD_DIR/%{name}-%{version}/%{name}-%{version}
  187. mkdir %{_tmppath}/salt-test-cache
  188. PYTHONPATH=%{pythonpath}:$RPM_BUILD_DIR/%{name}-%{version}/%{_salttesting}-%{_salttesting_ver} %{__python} setup.py test --runtests-opts=-u
  189. %endif
  190. %clean
  191. rm -rf %{buildroot}
  192. %files
  193. %defattr(-,root,root,-)
  194. %doc $RPM_BUILD_DIR/%{name}-%{version}/%{name}-%{version}/LICENSE
  195. %{python_sitelib}/%{name}/*
  196. #%{python_sitelib}/%{name}-%{version}-py?.?.egg-info
  197. %{python_sitelib}/%{name}-*-py?.?.egg-info
  198. %{_sysconfdir}/logrotate.d/salt
  199. %{_var}/cache/salt
  200. %doc $RPM_BUILD_DIR/%{name}-%{version}/%{name}-%{version}/README.fedora
  201. %files master
  202. %defattr(-,root,root)
  203. %doc %{_mandir}/man7/salt.7.*
  204. %doc %{_mandir}/man1/salt-cp.1.*
  205. %doc %{_mandir}/man1/salt-key.1.*
  206. %doc %{_mandir}/man1/salt-master.1.*
  207. %doc %{_mandir}/man1/salt-run.1.*
  208. %doc %{_mandir}/man1/salt-unity.1.*
  209. %{_bindir}/salt
  210. %{_bindir}/salt-cp
  211. %{_bindir}/salt-key
  212. %{_bindir}/salt-master
  213. %{_bindir}/salt-run
  214. %{_bindir}/salt-unity
  215. %if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
  216. %attr(0755, root, root) %{_initrddir}/salt-master
  217. %else
  218. %config(noreplace) %{_unitdir}/salt-master.service
  219. %endif
  220. %config(noreplace) %{_sysconfdir}/salt/master
  221. %files minion
  222. %defattr(-,root,root)
  223. %doc %{_mandir}/man1/salt-call.1.*
  224. %doc %{_mandir}/man1/salt-minion.1.*
  225. %{_bindir}/salt-minion
  226. %{_bindir}/salt-call
  227. %if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
  228. %attr(0755, root, root) %{_initrddir}/salt-minion
  229. %else
  230. %config(noreplace) %{_unitdir}/salt-minion.service
  231. %endif
  232. %config(noreplace) %{_sysconfdir}/salt/minion
  233. %files syndic
  234. %doc %{_mandir}/man1/salt-syndic.1.*
  235. %{_bindir}/salt-syndic
  236. %if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
  237. %attr(0755, root, root) %{_initrddir}/salt-syndic
  238. %else
  239. %config(noreplace) %{_unitdir}/salt-syndic.service
  240. %endif
  241. %files api
  242. %defattr(-,root,root)
  243. %doc %{_mandir}/man1/salt-api.1.*
  244. %{_bindir}/salt-api
  245. %if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
  246. %attr(0755, root, root) %{_initrddir}/salt-api
  247. %else
  248. %config(noreplace) %{_unitdir}/salt-api.service
  249. %endif
  250. %files cloud
  251. %doc %{_mandir}/man1/salt-cloud.1.*
  252. %{_bindir}/salt-cloud
  253. %{_sysconfdir}/salt/cloud.conf.d
  254. %{_sysconfdir}/salt/cloud.deploy.d
  255. %{_sysconfdir}/salt/cloud.maps.d
  256. %{_sysconfdir}/salt/cloud.profiles.d
  257. %{_sysconfdir}/salt/cloud.providers.d
  258. %config(noreplace) %{_sysconfdir}/salt/cloud
  259. %files ssh
  260. %doc %{_mandir}/man1/salt-ssh.1.*
  261. %{_bindir}/salt-ssh
  262. %{_sysconfdir}/salt/roster
  263. # less than RHEL 8 / Fedora 16
  264. # not sure if RHEL 7 will use systemd yet
  265. %if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
  266. %preun master
  267. if [ $1 -eq 0 ] ; then
  268. /sbin/service salt-master stop >/dev/null 2>&1
  269. /sbin/chkconfig --del salt-master
  270. fi
  271. %preun syndic
  272. if [ $1 -eq 0 ] ; then
  273. /sbin/service salt-syndic stop >/dev/null 2>&1
  274. /sbin/chkconfig --del salt-syndic
  275. fi
  276. %preun minion
  277. if [ $1 -eq 0 ] ; then
  278. /sbin/service salt-minion stop >/dev/null 2>&1
  279. /sbin/chkconfig --del salt-minion
  280. fi
  281. %post master
  282. /sbin/chkconfig --add salt-master
  283. %post minion
  284. /sbin/chkconfig --add salt-minion
  285. %postun master
  286. if [ "$1" -ge "1" ] ; then
  287. /sbin/service salt-master condrestart >/dev/null 2>&1 || :
  288. fi
  289. #%postun syndic
  290. # if [ "$1" -ge "1" ] ; then
  291. # /sbin/service salt-syndic condrestart >/dev/null 2>&1 || :
  292. # fi
  293. %postun minion
  294. if [ "$1" -ge "1" ] ; then
  295. /sbin/service salt-minion condrestart >/dev/null 2>&1 || :
  296. fi
  297. %else
  298. %preun master
  299. %if 0%{?systemd_preun:1}
  300. %systemd_preun salt-master.service
  301. %else
  302. if [ $1 -eq 0 ] ; then
  303. # Package removal, not upgrade
  304. /bin/systemctl --no-reload disable salt-master.service > /dev/null 2>&1 || :
  305. /bin/systemctl stop salt-master.service > /dev/null 2>&1 || :
  306. fi
  307. %endif
  308. %preun syndic
  309. %if 0%{?systemd_preun:1}
  310. %systemd_preun salt-syndic.service
  311. %else
  312. if [ $1 -eq 0 ] ; then
  313. # Package removal, not upgrade
  314. /bin/systemctl --no-reload disable salt-syndic.service > /dev/null 2>&1 || :
  315. /bin/systemctl stop salt-syndic.service > /dev/null 2>&1 || :
  316. fi
  317. %endif
  318. %preun minion
  319. %if 0%{?systemd_preun:1}
  320. %systemd_preun salt-minion.service
  321. %else
  322. if [ $1 -eq 0 ] ; then
  323. # Package removal, not upgrade
  324. /bin/systemctl --no-reload disable salt-minion.service > /dev/null 2>&1 || :
  325. /bin/systemctl stop salt-minion.service > /dev/null 2>&1 || :
  326. fi
  327. %endif
  328. %post master
  329. %if 0%{?systemd_post:1}
  330. %systemd_post salt-master.service
  331. %else
  332. /bin/systemctl daemon-reload &>/dev/null || :
  333. %endif
  334. %post minion
  335. %if 0%{?systemd_post:1}
  336. %systemd_post salt-minion.service
  337. %else
  338. /bin/systemctl daemon-reload &>/dev/null || :
  339. %endif
  340. %postun master
  341. %if 0%{?systemd_post:1}
  342. %systemd_postun salt-master.service
  343. %else
  344. /bin/systemctl daemon-reload &>/dev/null
  345. [ $1 -gt 0 ] && /bin/systemctl try-restart salt-master.service &>/dev/null || :
  346. %endif
  347. %postun syndic
  348. %if 0%{?systemd_post:1}
  349. %systemd_postun salt-syndic.service
  350. %else
  351. /bin/systemctl daemon-reload &>/dev/null
  352. [ $1 -gt 0 ] && /bin/systemctl try-restart salt-syndic.service &>/dev/null || :
  353. %endif
  354. %postun minion
  355. %if 0%{?systemd_post:1}
  356. %systemd_postun salt-minion.service
  357. %else
  358. /bin/systemctl daemon-reload &>/dev/null
  359. [ $1 -gt 0 ] && /bin/systemctl try-restart salt-minion.service &>/dev/null || :
  360. %endif
  361. %endif
  362. %changelog
  363. * Fri Mar 27 2015 Stephen Spencer <stephen@revsys.com> - 2014.7.2-2
  364. - avoid replacing the salt*.service files. Systemd ignores /etc/security/limits*
  365. in favor of directives entered in the service files.
  366. See systemd.directives(7), systemd.exec(5), systemd-system.conf(5)
  367. * Tue Feb 17 2015 Erik Johnson <erik@saltstack.com> - 2014.7.2-1
  368. - Update to bugfix release 2014.7.2
  369. * Mon Jan 19 2015 Erik Johnson <erik@saltstack.com> - 2014.7.1-1
  370. - Update to bugfix release 2014.7.1
  371. * Fri Nov 7 2014 Erik Johnson <erik@saltstack.com> - 2014.7.0-3
  372. - Make salt-api its own package
  373. * Thu Nov 6 2014 Erik Johnson <erik@saltstack.com> - 2014.7.0-2
  374. - Fix changelog
  375. * Thu Nov 6 2014 Erik Johnson <erik@saltstack.com> - 2014.7.0-1
  376. - Update to feature release 2014.7.0
  377. * Fri Oct 17 2014 Erik Johnson <erik@saltstack.com> - 2014.1.13-1
  378. - Update to bugfix release 2014.1.13
  379. * Mon Sep 29 2014 Erik Johnson <erik@saltstack.com> - 2014.1.11-1
  380. - Update to bugfix release 2014.1.11
  381. * Sun Aug 10 2014 Erik Johnson <erik@saltstack.com> - 2014.1.10-4
  382. - Fix incorrect conditional
  383. * Tue Aug 5 2014 Erik Johnson <erik@saltstack.com> - 2014.1.10-2
  384. - Deploy cachedir with package
  385. * Mon Aug 4 2014 Erik Johnson <erik@saltstack.com> - 2014.1.10-1
  386. - Update to bugfix release 2014.1.10
  387. * Thu Jul 10 2014 Erik Johnson <erik@saltstack.com> - 2014.1.7-3
  388. - Add logrotate script
  389. * Thu Jul 10 2014 Erik Johnson <erik@saltstack.com> - 2014.1.7-1
  390. - Update to bugfix release 2014.1.7
  391. * Wed Jun 11 2014 Erik Johnson <erik@saltstack.com> - 2014.1.5-1
  392. - Update to bugfix release 2014.1.5
  393. * Tue May 6 2014 Erik Johnson <erik@saltstack.com> - 2014.1.4-1
  394. - Update to bugfix release 2014.1.4
  395. * Thu Feb 20 2014 Erik Johnson <erik@saltstack.com> - 2014.1.0-1
  396. - Update to feature release 2014.1.0
  397. * Mon Jan 27 2014 Erik Johnson <erik@saltstack.com> - 0.17.5-1
  398. - Update to bugfix release 0.17.5
  399. * Thu Dec 19 2013 Erik Johnson <erik@saltstack.com> - 0.17.4-1
  400. - Update to bugfix release 0.17.4
  401. * Tue Nov 19 2013 Erik Johnson <erik@saltstack.com> - 0.17.2-2
  402. - Patched to fix pkgrepo.managed regression
  403. * Mon Nov 18 2013 Erik Johnson <erik@saltstack.com> - 0.17.2-1
  404. - Update to bugfix release 0.17.2
  405. * Thu Oct 17 2013 Erik Johnson <erik@saltstack.com> - 0.17.1-1
  406. - Update to bugfix release 0.17.1
  407. * Thu Sep 26 2013 Erik Johnson <erik@saltstack.com> - 0.17.0-1
  408. - Update to feature release 0.17.0
  409. * Wed Sep 11 2013 David Anderson <dave@dubkat.com>
  410. - Change sourcing order of init functions and salt default file
  411. * Sat Sep 07 2013 Erik Johnson <erik@saltstack.com> - 0.16.4-1
  412. - Update to patch release 0.16.4
  413. * Sun Aug 25 2013 Florian La Roche <Florian.LaRoche@gmx.net>
  414. - fixed preun/postun scripts for salt-minion
  415. * Thu Aug 15 2013 Andrew Niemantsverdriet <andrewniemants@gmail.com> - 0.16.3-1
  416. - Update to patch release 0.16.3
  417. * Thu Aug 8 2013 Clint Savage <herlo1@gmail.com> - 0.16.2-1
  418. - Update to patch release 0.16.2
  419. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16.0-2
  420. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  421. * Tue Jul 9 2013 Clint Savage <herlo1@gmail.com> - 0.16.0-1
  422. - Update to feature release 0.16.0
  423. * Sat Jun 1 2013 Clint Savage <herlo1@gmail.com> - 0.15.3-1
  424. - Update to patch release 0.15.3
  425. - Removed OrderedDict patch
  426. * Fri May 31 2013 Clint Savage <herlo1@gmail.com> - 0.15.2-1
  427. - Update to patch release 0.15.2
  428. - Patch OrderedDict for failed tests (SaltStack#4912)
  429. * Wed May 8 2013 Clint Savage <herlo1@gmail.com> - 0.15.1-1
  430. - Update to patch release 0.15.1
  431. * Sat May 4 2013 Clint Savage <herlo1@gmail.com> - 0.15.0-1
  432. - Update to upstream feature release 0.15.0
  433. * Fri Apr 19 2013 Clint Savage <herlo1@gmail.com> - 0.14.1-1
  434. - Update to upstream patch release 0.14.1
  435. * Sat Mar 23 2013 Clint Savage <herlo1@gmail.com> - 0.14.0-1
  436. - Update to upstream feature release 0.14.0
  437. * Fri Mar 22 2013 Clint Savage <herlo1@gmail.com> - 0.13.3-1
  438. - Update to upstream patch release 0.13.3
  439. * Wed Mar 13 2013 Clint Savage <herlo1@gmail.com> - 0.13.2-1
  440. - Update to upstream patch release 0.13.2
  441. * Fri Feb 15 2013 Clint Savage <herlo1@gmail.com> - 0.13.1-1
  442. - Update to upstream patch release 0.13.1
  443. - Add unittest support
  444. * Sat Feb 02 2013 Clint Savage <herlo1@gmail.com> - 0.12.1-1
  445. - Remove patches and update to upstream patch release 0.12.1
  446. * Thu Jan 17 2013 Wendall Cada <wendallc@83864.com> - 0.12.0-2
  447. - Added unittest support
  448. * Wed Jan 16 2013 Clint Savage <herlo1@gmail.com> - 0.12.0-1
  449. - Upstream release 0.12.0
  450. * Fri Dec 14 2012 Clint Savage <herlo1@gmail.com> - 0.11.1-1
  451. - Upstream patch release 0.11.1
  452. - Fixes security vulnerability (https://github.com/saltstack/salt/issues/2916)
  453. * Fri Dec 14 2012 Clint Savage <herlo1@gmail.com> - 0.11.0-1
  454. - Moved to upstream release 0.11.0
  455. * Wed Dec 05 2012 Mike Chesnut <mchesnut@gmail.com> - 0.10.5-2
  456. - moved to upstream release 0.10.5
  457. - removing references to minion.template and master.template, as those files
  458. have been removed from the repo
  459. * Sun Nov 18 2012 Clint Savage <herlo1@gmail.com> - 0.10.5-1
  460. - Moved to upstream release 0.10.5
  461. - Added pciutils as Requires
  462. * Wed Oct 24 2012 Clint Savage <herlo1@gmail.com> - 0.10.4-1
  463. - Moved to upstream release 0.10.4
  464. - Patched jcollie/systemd-service-status (SALT@GH#2335) (RHBZ#869669)
  465. * Tue Oct 2 2012 Clint Savage <herlo1@gmail.com> - 0.10.3-1
  466. - Moved to upstream release 0.10.3
  467. - Added systemd scriplets (RHBZ#850408)
  468. * Thu Aug 2 2012 Clint Savage <herlo1@gmail.com> - 0.10.2-2
  469. - Fix upstream bug #1730 per RHBZ#845295
  470. * Tue Jul 31 2012 Clint Savage <herlo1@gmail.com> - 0.10.2-1
  471. - Moved to upstream release 0.10.2
  472. - Removed PyXML as a dependency
  473. * Sat Jun 16 2012 Clint Savage <herlo1@gmail.com> - 0.10.1-1
  474. - Moved to upstream release 0.10.1
  475. * Sat Apr 28 2012 Clint Savage <herlo1@gmail.com> - 0.9.9.1-1
  476. - Moved to upstream release 0.9.9.1
  477. * Tue Apr 17 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 0.9.8-2
  478. - dmidecode is x86 only
  479. * Wed Mar 21 2012 Clint Savage <herlo1@gmail.com> - 0.9.8-1
  480. - Moved to upstream release 0.9.8
  481. * Thu Mar 8 2012 Clint Savage <herlo1@gmail.com> - 0.9.7-2
  482. - Added dmidecode as a Requires
  483. * Thu Feb 16 2012 Clint Savage <herlo1@gmail.com> - 0.9.7-1
  484. - Moved to upstream release 0.9.7
  485. * Tue Jan 24 2012 Clint Savage <herlo1@gmail.com> - 0.9.6-2
  486. - Added README.fedora and removed deps for optional modules
  487. * Sat Jan 21 2012 Clint Savage <herlo1@gmail.com> - 0.9.6-1
  488. - New upstream release
  489. * Sun Jan 8 2012 Clint Savage <herlo1@gmail.com> - 0.9.4-6
  490. - Missed some critical elements for SysV and rpmlint cleanup
  491. * Sun Jan 8 2012 Clint Savage <herlo1@gmail.com> - 0.9.4-5
  492. - SysV clean up in post
  493. * Sat Jan 7 2012 Clint Savage <herlo1@gmail.com> - 0.9.4-4
  494. - Cleaning up perms, group and descriptions, adding post scripts for systemd
  495. * Thu Jan 5 2012 Clint Savage <herlo1@gmail.com> - 0.9.4-3
  496. - Updating for systemd on Fedora 15+
  497. * Thu Dec 1 2011 Clint Savage <herlo1@gmail.com> - 0.9.4-2
  498. - Removing requirement for Cython. Optional only for salt-minion
  499. * Wed Nov 30 2011 Clint Savage <herlo1@gmail.com> - 0.9.4-1
  500. - New upstream release with new features and bugfixes
  501. * Thu Nov 17 2011 Clint Savage <herlo1@gmail.com> - 0.9.3-1
  502. - New upstream release with new features and bugfixes
  503. * Sat Sep 17 2011 Clint Savage <herlo1@gmail.com> - 0.9.2-1
  504. - Bugfix release from upstream to fix python2.6 issues
  505. * Fri Sep 09 2011 Clint Savage <herlo1@gmail.com> - 0.9.1-1
  506. - Initial packages