PKGBUILD-local 869 B

12345678910111213141516171819202122232425262728293031323334
  1. # Maintainer: Thomas S Hatch <thatch45 at gmail dot com>
  2. # Build the salt package from local files.
  3. # Use this to test Arch installation before committing changes.
  4. pkgname=salt
  5. pkgver=$(date +%Y%m%d)
  6. pkgrel=1
  7. pkgdesc="A remote execution and communication system built on zeromq"
  8. arch=('any')
  9. url="https://github.com/thatch45/salt"
  10. license=('APACHE')
  11. groups=()
  12. depends=('python2'
  13. 'python2-pyzmq'
  14. 'python-m2crypto'
  15. 'python2-yaml'
  16. 'pycrypto'
  17. 'python2-psutil')
  18. makedepends=('git')
  19. provides=()
  20. backup=('etc/salt/master'
  21. 'etc/salt/minion')
  22. options=()
  23. srcdir="$PWD/../.."
  24. package() {
  25. cd "$srcdir"
  26. python2 setup.py install --root=$pkgdir/ --optimize=1
  27. mkdir -p $pkgdir/etc/rc.d/
  28. cp $srcdir/pkg/arch/salt-master $pkgdir/etc/rc.d/
  29. cp $srcdir/pkg/arch/salt-minion $pkgdir/etc/rc.d/
  30. chmod +x $pkgdir/etc/rc.d/*
  31. }